Инструменты пользователя

Инструменты сайта


mikrotik:rb3011uias:routeros:system:scripts:lcd

Скрипт для удаленного управления LCD экраном MiktoTik RB3011

Простейший скрипт, был написан, когда железка стояла дома и настраивалась мной - лег спать, а экран светит на всю комнату, вставать лень… LOL

Комментарии к коду

Скрипт может включить/выключить или усыпить/разбудить LCD экран. Если усыпить экран, то ткнув пальцем по нему его можно разбудить, а если его выключить, то так уже не получится.

/lcd {
:if ( $mode = "on" ) do={ set enabled=yes; }
:if ( $mode = "off" ) do={ set enabled=no; }
:if ( $mode = "sleep" ) do={
  :global sendEvent;
  $sendEvent mode=sms msg="Good night! :)";
  backlight state=off; }
:if ( $mode = "wake" ) do={ backlight state=on; }
}

Код для импорта

lcd.rsc
/system script
add comment="\D3\E4\E0\EB\E5\ED\ED\EE\E5 \F3\EF\F0\E0\E2\EB\E5\ED\E8\E5 LCD \
    \FD\EA\F0\E0\ED\EE\EC" dont-require-permissions=no name=lcd owner=petya \
    policy=read,write,policy,test source="# Written by Nikolay Soloshin (nikol\
    ay@soloshin.su) for RouterOS v6.46.3 on RB3011UiAS (arm) @ 2020.03\r\
    \n\r\
    \n/lcd {\r\
    \n:if ( \$mode = \"on\" ) do={ set enabled=yes; }\r\
    \n:if ( \$mode = \"off\" ) do={ set enabled=no; }\r\
    \n:if ( \$mode = \"sleep\" ) do={\r\
    \n  :global sendEvent;\r\
    \n  \$sendEvent mode=sms msg=\"Good night! :)\";\r\
    \n  backlight state=off; }\r\
    \n:if ( \$mode = \"wake\" ) do={ backlight state=on; }\r\
    \n}\r\
    \n\r\
    \n# With love from Vladivostok."

Запуск скрипта

Скрипт запускается через SMS на номер модема с синтаксисом :cmd 12345 script lcd mode=variable, где 12345, это секрет, назначенный при настройке приема SMS, а variable - одна из поддерживаемых переменных.

Политики запуска

Это минимально необходимый набор для работы скрипта.

  • read,
  • write,
  • policy,
  • test.

Дисклеймер

  • Использование материалов данной базы знаний разрешено на условиях лицензии, указанной внизу каждой страницы! При использовании материалов активная гиперссылка на соответствующую страницу данной базы знаний обязательна!
  • Автор не несет и не может нести какую либо ответственность за последствия использования материалов, размещенных в данной базе знаний. Все материалы предоставляются по принципу «как есть». Используйте их исключительно на свой страх и риск.
  • Все высказывания, мысли или идеи автора, размещенные в материалах данной базе знаний, являются исключительно его личным субъективным мнением и могут не совпадать с мнением читателей!
  • При размещении ссылок в данной базе знаний на интернет-страницы третьих лиц автор не несет ответственности за их техническую функциональность (особенно отсутствие вирусов) и содержание! При обнаружении таких ссылок, можно и желательно сообщить о них в комментариях к соответствующей статье.

Обсуждение

Ваш комментарий:
H E L​ W E D B H W᠎ L J M C P D H
 
Последнее изменение: 2022/02/12 11:40 (внешнее изменение)