Инструменты пользователя

Инструменты сайта


mikrotik:rb3011uias:routeros:system:scripts:help

Доступные команды для управления MikroTik по SMS

Это простой, но удобный скрипт для напоминания о возможных SMS командах.

Комментарии к коду

Инициализируем функцию отправки SMS и Email.

:global sendEvent;

Подготавливаем текст SMS. Можно использовать перенос строки \r\n.

:!: Важно помнить, что RouterOS не умеет резать SMS на фрагменты! Длина сообщения не должна превышать 160 символов.

:local help "* modem mode=(on|off|test|reset) [remote=on];\r\n* failover channel=(auto|primary|backup|test);\r\n* lcd mode=(on|off|sleep|wake);\r\n* reboot;\r\n* state";

Отправляем сообщение в надежном режиме.

$sendEvent msg=$help;

Код для импорта

help.rsc
/system script
add comment="\C4\EE\F1\F2\F3\EF\ED\FB\E5 \EA\EE\EC\E0\ED\E4\FB \E4\EB\FF \F3\
    \EF\F0\E0\E2\EB\E5\ED\E8\FF \EF\EE SMS" dont-require-permissions=no name=\
    help owner=petya policy=read,write,policy,test source="# Written by Nikola\
    y Soloshin (nikolay@soloshin.su) for RouterOS v6.46.3 on RB3011UiAS (arm) \
    @ 2020.03\r\
    \n\r\
    \n# Functions used in the script. They are entered by the script \"variabl\
    e-initialization\" when the device starts!\r\
    \n:global sendEvent;\r\
    \n\r\
    \n:local help \"* modem mode=(on|off|test|reset) [remote=on];\\r\\n* failo\
    ver channel=(auto|primary|backup|test);\\r\\n* lcd mode=(on|off|sleep|wake\
    );\\r\\n* reboot;\\r\\n* state\";\r\
    \n\r\
    \n\$sendEvent msg=\$help;\r\
    \n\r\
    \n# With love from Vladivostok."

Запуск скрипта

Скрипт запускается через SMS на номер модема с синтаксисом :cmd 12345 script help, где 12345, это секрет, назначенный при настройке приема SMS.

Пример ответной SMS

* modem mode=(on|off|test|reset) [remote=on];
* failover channel=(auto|primary|backup|test);
* lcd mode=(on|off|sleep|wake);
* reboot;
* state.

Переменные

Управление USB-модемом (modem)

Переменная Значение Комментарий
mode (обязательный) on Подключение модема
off Отключение модема
test Тестирование связи
reset Аппаратный сброс
remote (не обязательный) on Включение удаленного доступа

Параметр remote=on может использоваться как совместно с mode=on так и отдельно, к примеру, :cmd 12345 script modem remote=on. Подробнее.

Управление Интернет-каналами (failover)

Переменная Значение Комментарий
channel (обязательный) auto Автоматический выбор канала
primary Только основной канал
backup Только резервный канал
test Ручное тестирование каналов

При переключении скрипта в режим primary или backup задание в планировщике отключается и периодические проверки не проводятся до переключения скрипта в режим auto! Подробнее.

Управление LCD-экраном (lcd)

Переменная Значение Комментарий
mode (обязательный) on Включить экран
off Выключить экран
sleep Усыпить экран
wake Разбудить экран

По сути, последние две переменные только включают и выключают подсветку, т.е. после sleep можно нажать на экран пальцем и он загорится, а после off уже нет. Подробнее.

Прочие команды

Команды reboot и state переменных и параметров не имеют и выполняют только одну функцию.

Политики запуска

Это минимально необходимый набор для работы скрипта.

  • read,
  • write,
  • policy,
  • test.

Дисклеймер

  • Использование материалов данной базы знаний разрешено на условиях лицензии, указанной внизу каждой страницы! При использовании материалов активная гиперссылка на соответствующую страницу данной базы знаний обязательна!
  • Автор не несет и не может нести какую либо ответственность за последствия использования материалов, размещенных в данной базе знаний. Все материалы предоставляются по принципу «как есть». Используйте их исключительно на свой страх и риск.
  • Все высказывания, мысли или идеи автора, размещенные в материалах данной базе знаний, являются исключительно его личным субъективным мнением и могут не совпадать с мнением читателей!
  • При размещении ссылок в данной базе знаний на интернет-страницы третьих лиц автор не несет ответственности за их техническую функциональность (особенно отсутствие вирусов) и содержание! При обнаружении таких ссылок, можно и желательно сообщить о них в комментариях к соответствующей статье.

Обсуждение

Ваш комментарий:
O D᠎ H B U H V C W᠎ P C᠎ D Q S B V
 
Последнее изменение: 2022/02/12 11:40 (внешнее изменение)