Инструменты пользователя

Инструменты сайта


mikrotik:rb3011uias:routeros:system:scripts:reboot

Скрипт для удаленной перезагрузки MikroTik

Опять же, простейший скрипт, который может помочь сохранить пару волосинок на черепе админа.

Комментарии к коду

Инициализируем функцию отправки SMS и Email.

:global sendEvent;

Набираем сообщение в переменную.

:local msgReboot "Rebooting MikroTik RB3011...";

Отправляем и перезагружаемся.

$sendEvent mode=sms msg=$msgReboot;
:delay 5s;
/system reboot

Теперь осталось дождаться ответной SMS от скрипта запуска и идти отдыхать дальше. ^_^

Код для импорта

reboot.rsc
/system script
add comment="\D3\E4\E0\EB\E5\ED\E0\FF \EF\E5\F0\E5\E7\E0\E3\F0\F3\E7\EA\E0 \F3\
    \F1\F2\F0\EE\E9\F1\F2\E2\E0 \E8 \EE\F2\EF\F0\E0\E2\EA\E0 SMS" \
    dont-require-permissions=no name=reboot owner=petya policy=\
    reboot,read,write,policy,test source="# Written by Nikolay Soloshin (nikol\
    ay@soloshin.su) for RouterOS v6.46.3 on RB3011UiAS (arm) @ 2020.03\r\
    \n\r\
    \n# Functions used in the script. They are entered by the script \"variabl\
    e-initialization\" when the device starts!\r\
    \n:global sendEvent;\r\
    \n\r\
    \n:local msgReboot \"Rebooting MikroTik RB3011...\";\r\
    \n\r\
    \n\$sendEvent mode=sms msg=\$msgReboot;\r\
    \n:delay 5s;\r\
    \n/system reboot\r\
    \n\r\
    \n# With love from Vladivostok."

Запуск скрипта

Скрипт запускается через SMS на номер модема с синтаксисом :cmd 12345 script reboot, где 12345, это секрет, назначенный при настройке приема SMS.

Политики запуска

Это минимально необходимый набор для работы скрипта.

  • reboot,
  • read,
  • write,
  • policy,
  • test.

Дисклеймер

  • Использование материалов данной базы знаний разрешено на условиях лицензии, указанной внизу каждой страницы! При использовании материалов активная гиперссылка на соответствующую страницу данной базы знаний обязательна!
  • Автор не несет и не может нести какую либо ответственность за последствия использования материалов, размещенных в данной базе знаний. Все материалы предоставляются по принципу «как есть». Используйте их исключительно на свой страх и риск.
  • Все высказывания, мысли или идеи автора, размещенные в материалах данной базе знаний, являются исключительно его личным субъективным мнением и могут не совпадать с мнением читателей!
  • При размещении ссылок в данной базе знаний на интернет-страницы третьих лиц автор не несет ответственности за их техническую функциональность (особенно отсутствие вирусов) и содержание! При обнаружении таких ссылок, можно и желательно сообщить о них в комментариях к соответствующей статье.

Обсуждение

Ваш комментарий:
G R N X I I C P C N S J T A N P
 
Последнее изменение: 2022/02/12 11:40 (внешнее изменение)