Инструменты пользователя

Инструменты сайта


mikrotik:rb3011uias:routeros:system:scripts:trial_cookies_delete

Периодическое удаление trial-cookies HotSpot

FIXME Параметры Cookie и Trial в Hotspot → Server Profiles → Login не полностью совместимы - при наличии куки-файла гостевого пользователя, для последнего не правильно считается Trial Uptime Limit. А если отключить Cookie, авторизованным пользователям ноутбуков каждый раз приходится вводить логин и пароль.

Комментарии к коду

Хм-м? Собственно, а какие тут могут быть комментарии! Все просто - ищем куки, начинающиеся с T- и удаляем их!

/ip hotspot cookie {
  :if ( [find user~"T-"] ) do={
    remove [find user~"T-"];
   :log info ("HotSpot trial cookies removed!"); }
}

Код для импорта

trial-cookies-delete.rsc
/system script
add comment="\CF\E5\F0\E8\EE\E4\E8\F7\E5\F1\EA\EE\E5 \F3\E4\E0\EB\E5\ED\E8\E5 \
    trial-cookies \F5\EE\F2\EF\EE\F1\F2\E0" dont-require-permissions=no name=\
    trial-cookies-delete owner=petya policy=read,write source="# Written by Ni\
    kolay Soloshin (nikolay@soloshin.su) for RouterOS v6.46.3 on RB3011UiAS (a\
    rm) @ 2020.03\r\
    \n\r\
    \n# \CF\E0\F0\E0\EC\E5\F2\F0\FB Cookie \E8 Trial \E2 Hotspot - Server Prof\
    iles - Login \ED\E5 \EF\EE\EB\ED\EE\F1\F2\FC\FE \F1\EE\E2\EC\E5\F1\F2\E8\
    \EC\FB - \EF\F0\E8 \ED\E0\EB\E8\F7\E8\E8 \EA\F3\EA\E8-\F4\E0\E9\EB\E0 \E3\
    \EE\F1\F2\E5\E2\EE\E3\EE \EF\EE\EB\FC\E7\EE\E2\E0\F2\E5\EB\FF, \E4\EB\FF \
    \EF\EE\F1\EB\E5\E4\ED\E5\E3\EE \ED\E5 \EF\F0\E0\E2\E8\EB\FC\ED\EE \F1\F7\
    \E8\F2\E0\E5\F2\F1\FF Trial Uptime Limit. \C0 \E5\F1\EB\E8 \EE\F2\EA\EB\FE\
    \F7\E8\F2\FC Cookie, \E0\E2\F2\EE\F0\E8\E7\EE\E2\E0\ED\ED\FB\EC \EF\EE\EB\
    \FC\E7\EE\E2\E0\F2\E5\EB\FF\EC \ED\EE\F3\F2\E1\F3\EA\EE\E2 \EA\E0\E6\E4\FB\
    \E9 \F0\E0\E7 \EF\F0\E8\F5\EE\E4\E8\F2\F1\FF \E2\E2\EE\E4\E8\F2\FC \EB\EE\
    \E3\E8\ED \E8 \EF\E0\F0\EE\EB\FC.\r\
    \n\r\
    \n/ip hotspot cookie {\r\
    \n  :if ( [find user~\"T-\"] ) do={\r\
    \n    remove [find user~\"T-\"];\r\
    \n   :log info (\"HotSpot trial cookies removed!\"); }\r\
    \n}\r\
    \n\r\
    \n# With love from Vladivostok."

Запуск скрипта

Скрипт должен выполняться периодически, в зависимости от количества активных пользователей. Параметры запуска смотрите в соответствующем разделе.

Политики запуска

Это минимально необходимый набор для работы скрипта.

  • read,
  • write.

Дисклеймер

  • Использование материалов данной базы знаний разрешено на условиях лицензии, указанной внизу каждой страницы! При использовании материалов активная гиперссылка на соответствующую страницу данной базы знаний обязательна!
  • Автор не несет и не может нести какую либо ответственность за последствия использования материалов, размещенных в данной базе знаний. Все материалы предоставляются по принципу «как есть». Используйте их исключительно на свой страх и риск.
  • Все высказывания, мысли или идеи автора, размещенные в материалах данной базе знаний, являются исключительно его личным субъективным мнением и могут не совпадать с мнением читателей!
  • При размещении ссылок в данной базе знаний на интернет-страницы третьих лиц автор не несет ответственности за их техническую функциональность (особенно отсутствие вирусов) и содержание! При обнаружении таких ссылок, можно и желательно сообщить о них в комментариях к соответствующей статье.

Обсуждение

Ваш комментарий:
Y P O G K R V V X X V J A A G X
 
Последнее изменение: 2022/02/12 11:40 (внешнее изменение)