Инструменты пользователя

Инструменты сайта


mikrotik:rb952ui-5ac2nd-tc:routeros:ip:vrf

Настройка VRF на MikroTik

Имеется маршрутизатор hAP ac lite TC (RouterOS 7.8) с внутренней сетью 192.168.0.0/24, который подключается не напрямую к сети провайдера, а посредством произвольного родительского маршрутизатора, получив от него по DHCP соответствующие настройки. При том, что внутренняя сеть последнего заранее не известна и вполне может оказаться той же, что и на гостевом устройстве, т.е. 192.168.0.0/24, а это обеспечит стопроцентный1) конфликт маршрутизации внутри гостевого устройства.

В процессе решения задачи перепробовал огромное количество разных идей, что своих, что почерпнутых с просторов Интернета, ни одна из которых, увы, не сработала. Но с этим всем пришло понимание, в какую сторону нужно продолжать смотреть – изоляция интерфейса, смотрящего во вне, и внутреннего моста. И тут я случайно наткнулся на статью, которая, вроде, и была не совсем в тему, но…

Настройка

В общем, решение данной задачи заключается в выделении моста2) в отдельную виртуальную таблицу маршрутизации (VRF, Virtual Routing and Forwarding):

/ip vrf add name="VRF 1" interfaces="Bridge 1"

Помимо этого, необходимо переместить используемые в этой сети сервисы в новую таблицу, иначе они могут перестать работать! В моем случае, это публикация порта WinBox3) и NTP-клиент:

/ip/service set winbox vrf="VRF 1"
/system/ntp/client set vrf="VRF 1"

Полный список сервисов и методов их перемещения указан в официальной документации.


Дисклеймер

  • Использование материалов данной базы знаний разрешено на условиях лицензии, указанной внизу каждой страницы! При использовании материалов активная гиперссылка на соответствующую страницу данной базы знаний обязательна!
  • Автор не несет и не может нести какую либо ответственность за последствия использования материалов, размещенных в данной базе знаний. Все материалы предоставляются по принципу «как есть». Используйте их исключительно на свой страх и риск.
  • Все высказывания, мысли или идеи автора, размещенные в материалах данной базе знаний, являются исключительно его личным субъективным мнением и могут не совпадать с мнением читателей!
  • При размещении ссылок в данной базе знаний на интернет-страницы третьих лиц автор не несет ответственности за их техническую функциональность (особенно отсутствие вирусов) и содержание! При обнаружении таких ссылок, можно и желательно сообщить о них в комментариях к соответствующей статье.
1)
Проверено суровой практикой на тестовом стенде, когда все мои надежды, что пронесет, пошли прахом!
2)
Да, только моста! – опять же, перепробовал много разных вариантов, этот оказался единственным рабочим во всех ситуациях.
3)
К слову, WinBox вероятнее всего таки сломается и не будет доступен по IP – нужно просто временно подключиться по MAC.

Обсуждение

Ваш комментарий:
H W J R I Q᠎ V T N L᠎ C N D N Z P
 
Последнее изменение: 2023/03/09 21:03 — Николай Солошин